Symptomy

Przy próbie wygenerowania zestawienia z dużą ilością danych może pojawić się komunikat: "Przekroczenie czasu oczekiwania na odpowiedź serwera (timeout)" lub podobny, informujący o przekroczeniu czasu oczekiwania na odpowiedź serwera. Innym symptomem może być niemożność przeprowadzenia odbudowy danych InsTYNKT-u wykonywana z poziomu Programu Serwisowego.

 

Przyczyna

Przyczyną takiego zachowania jest tak duży zakres danych do przetworzenia, iż w oczekiwanym przez program czasie nie nastąpiła odpowiedź. Domyślnie czasem tym jest 30 sekund.  

 

Rozwiązanie

Użytkownik może wybrać jedno z dwóch rozwiązań: albo zmniejszyć zakres przetwarzanych danych (np. zawężając okres wyliczania zestawienia, które się nie wykonało), albo zwiększyć ustawienie czasu oczekiwania programu na odpowiedź serwera.

W tym drugim przypadku należy:  

Z poziomu wiersza poleceń (Start ® Uruchom) należy wykonać następującą komendę:

Regedit <OK/Otwórz>

Następnie odnaleźć ścieżkę:  HKEY_CURRENT_USER\Software\InsERT\InsERT GT\dbman\1.0\Connection Properties i dodać nową wartość (DWORD) o nazwie: Command Timeout równej wartości żądanego timeout'u w sekundach. 

Jeśli zostanie wprowadzona 0 (słownie: zero), spowoduje to wyłączenie ograniczenia czasowego na odpowiedź serwera.

Po zakończeniu operacji należy ponownie uruchomić program.

 

Wyłączenie czasu oczekiwania może mieć niekorzystny wpływ na działanie programu - jeśli serwer w ogóle nie odeśle informacji zwrotnej (np. na skutek awarii), program będzie nieustannie czekać na odpowiedź.



W załączniku został umieszczony plik archiwum. Po jego rozpakowaniu dostępny będzie plik timeout.reg którego uruchomienie spowoduje zmianę w rejestrze opisaną powyżej. 



Źródło

-------

Pomoc Insert